summaryrefslogtreecommitdiff
path: root/unittests/AST/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Klimek <klimek@google.com>2013-06-03 13:51:33 +0000
committerManuel Klimek <klimek@google.com>2013-06-03 13:51:33 +0000
commitf0f353b36f173ea282209070fcdbbedab84c19db (patch)
tree77ea2a6c1c92de014ace8b5695a09ec4867baf0a /unittests/AST/CMakeLists.txt
parentce912f45660613c1bc49696eb07ff7f8aecffe18 (diff)
downloadclang-f0f353b36f173ea282209070fcdbbedab84c19db.tar.gz
Fix memory leak for APValues that do memory allocation.
This patch ensures that APValues are deallocated with the ASTContext by registering a deallocation function for APValues to the ASTContext. Original version of the patch by James Dennett. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@183101 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/AST/CMakeLists.txt')
-rw-r--r--unittests/AST/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/unittests/AST/CMakeLists.txt b/unittests/AST/CMakeLists.txt
index ad29428220..3ef2a5e153 100644
--- a/unittests/AST/CMakeLists.txt
+++ b/unittests/AST/CMakeLists.txt
@@ -3,6 +3,7 @@ add_clang_unittest(ASTTests
CommentLexer.cpp
CommentParser.cpp
DeclPrinterTest.cpp
+ DeclTest.cpp
SourceLocationTest.cpp
StmtPrinterTest.cpp
)