summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorTed Kremenek <kremenek@apple.com>2011-08-09 03:39:19 +0000
committerTed Kremenek <kremenek@apple.com>2011-08-09 03:39:19 +0000
commit2dc651dfd4a4497c39b862e060200d6d58f5c4ec (patch)
treea3c2d8d58466a7d2b62a44b512f98f432c50b949 /tools/CMakeLists.txt
parent6948bc4bcbd92502d90b877780a3b746275efa5b (diff)
downloadclang-2dc651dfd4a4497c39b862e060200d6d58f5c4ec.tar.gz
Add 'diagtool' to the 'tools/' directory. diagtool is a new tool (WIP) for analyzing and working with clang diagnostics.
Some interesting stats from 'diagtool list-warnings' on the current version of clang: Percentage of warnings with flags: 48.79% Number of unique flags: 148 Average number of diagnostics per flag: 2.041 git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@137109 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 1b5252e050..1bca496eaa 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -1,5 +1,6 @@
add_subdirectory(arcmt-test)
add_subdirectory(c-arcmt-test)
add_subdirectory(c-index-test)
+add_subdirectory(diagtool)
add_subdirectory(driver)
add_subdirectory(libclang)