summaryrefslogtreecommitdiff
path: root/test/CXX/temp/temp.spec/temp.explicit/p2.cpp
diff options
context:
space:
mode:
authorDouglas Gregor <dgregor@apple.com>2009-10-15 14:05:49 +0000
committerDouglas Gregor <dgregor@apple.com>2009-10-15 14:05:49 +0000
commite2d3a3de71b2fa35614cb732a6da95a41fa38ad9 (patch)
treef59f0a8f3395319bf7cf5e2e065bc4e71ac8cc76 /test/CXX/temp/temp.spec/temp.explicit/p2.cpp
parentbf7643e7966cd9acd797a84870018034112e49d3 (diff)
downloadclang-e2d3a3de71b2fa35614cb732a6da95a41fa38ad9.tar.gz
Diagnose explicit instantiations of function templates and member
functions/static data members of class template specializations that do not have definitions. This is the latter part of [temp.explicit]p4; the former part still needs more testing. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@84182 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CXX/temp/temp.spec/temp.explicit/p2.cpp')
-rw-r--r--test/CXX/temp/temp.spec/temp.explicit/p2.cpp2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/CXX/temp/temp.spec/temp.explicit/p2.cpp b/test/CXX/temp/temp.spec/temp.explicit/p2.cpp
index aee0e5d19d..f3d2c955cb 100644
--- a/test/CXX/temp/temp.spec/temp.explicit/p2.cpp
+++ b/test/CXX/temp/temp.spec/temp.explicit/p2.cpp
@@ -35,7 +35,7 @@ namespace N {
};
template<typename T>
- void f1(T); // expected-note{{explicit instantiation refers here}}
+ void f1(T) {}; // expected-note{{explicit instantiation refers here}}
}
using namespace N;