summaryrefslogtreecommitdiff
path: root/lib/StaticAnalyzer/Core/CMakeLists.txt
diff options
context:
space:
mode:
authorIlya Biryukov <ibiryukov@google.com>2018-03-01 14:54:16 +0000
committerIlya Biryukov <ibiryukov@google.com>2018-03-01 14:54:16 +0000
commitc476211d8b3b3fe69b7166c86bd88e3e09113371 (patch)
tree329e8e44c285c79c6b0e94d16b433c43d320457f /lib/StaticAnalyzer/Core/CMakeLists.txt
parente9c5141c8f3310da5fe63bdda25128eae13394ca (diff)
downloadclang-c476211d8b3b3fe69b7166c86bd88e3e09113371.tar.gz
Resubmit [analyzer] Support for naive cross translation unit analysis
Originally submitted as r326323 and r326324. Reverted in r326432. Reverting the commit was a mistake. The breakage was due to invalid build files in our internal buildsystem, CMakeLists did not have any cyclic dependencies. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@326439 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/StaticAnalyzer/Core/CMakeLists.txt')
-rw-r--r--lib/StaticAnalyzer/Core/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/StaticAnalyzer/Core/CMakeLists.txt b/lib/StaticAnalyzer/Core/CMakeLists.txt
index 5ac4f942f3..436a8a2d8b 100644
--- a/lib/StaticAnalyzer/Core/CMakeLists.txt
+++ b/lib/StaticAnalyzer/Core/CMakeLists.txt
@@ -58,6 +58,7 @@ add_clang_library(clangStaticAnalyzerCore
clangASTMatchers
clangAnalysis
clangBasic
+ clangCrossTU
clangLex
clangRewrite
${Z3_LINK_FILES}