summaryrefslogtreecommitdiff
path: root/lib/Rewrite/CMakeLists.txt
diff options
context:
space:
mode:
authorDmitri Gribenko <gribozavr@gmail.com>2012-07-06 00:28:32 +0000
committerDmitri Gribenko <gribozavr@gmail.com>2012-07-06 00:28:32 +0000
commit8d3ba23f2d9e6c87794d059412a0808c9cbacb25 (patch)
treec72c618faeffa1c098c4df33857bd12a72c62fb1 /lib/Rewrite/CMakeLists.txt
parent1838703fea568b394407b83d1055b4c7f52fb105 (diff)
downloadclang-8d3ba23f2d9e6c87794d059412a0808c9cbacb25.tar.gz
Implement AST classes for comments, a real parser for Doxygen comments and a
very simple semantic analysis that just builds the AST; minor changes for lexer to pick up source locations I didn't think about before. Comments AST is modelled along the ideas of HTML AST: block and inline content. * Block content is a paragraph or a command that has a paragraph as an argument or verbatim command. * Inline content is placed within some block. Inline content includes plain text, inline commands and HTML as tag soup. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@159790 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Rewrite/CMakeLists.txt')
-rw-r--r--lib/Rewrite/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Rewrite/CMakeLists.txt b/lib/Rewrite/CMakeLists.txt
index daf9605834..d8d90fa278 100644
--- a/lib/Rewrite/CMakeLists.txt
+++ b/lib/Rewrite/CMakeLists.txt
@@ -17,6 +17,7 @@ add_clang_library(clangRewrite
add_dependencies(clangRewrite
ClangAttrClasses
ClangAttrList
+ ClangCommentNodes
ClangDeclNodes
ClangStmtNodes
)