summaryrefslogtreecommitdiff
path: root/lib/Driver/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Lorenz <arphaman@gmail.com>2018-12-17 19:19:15 +0000
committerAlex Lorenz <arphaman@gmail.com>2018-12-17 19:19:15 +0000
commit228f2c50c5313094fa41671e6ac2d1548db7d19d (patch)
tree4fa43edefd07bf14fc1f58c62999da5764b8ce9b /lib/Driver/CMakeLists.txt
parentdbc63abadbe81029b9f65b6e8160046fa26f1646 (diff)
downloadclang-228f2c50c5313094fa41671e6ac2d1548db7d19d.tar.gz
[darwin] parse the SDK settings from SDKSettings.json if it exists and
pass in the -target-sdk-version to the compiler and backend This commit adds support for reading the SDKSettings.json file in the Darwin driver. This file is used by the driver to determine the SDK's version, and it uses that information to pass it down to the compiler using the new -target-sdk-version= option. This option is then used to set the appropriate SDK Version module metadata introduced in r349119. Note: I had to adjust the two ast tests as the SDKROOT environment variable on macOS caused SDK version to be picked up for the compilation of source file but not the AST. rdar://45774000 Differential Revision: https://reviews.llvm.org/D55673 git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@349380 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Driver/CMakeLists.txt')
-rw-r--r--lib/Driver/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Driver/CMakeLists.txt b/lib/Driver/CMakeLists.txt
index bc96098d0a..084176b524 100644
--- a/lib/Driver/CMakeLists.txt
+++ b/lib/Driver/CMakeLists.txt
@@ -12,6 +12,7 @@ endif()
add_clang_library(clangDriver
Action.cpp
Compilation.cpp
+ DarwinSDKInfo.cpp
Distro.cpp
Driver.cpp
DriverOptions.cpp