summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2008-10-26 00:56:18 +0000
committerOscar Fuentes <ofv@wanadoo.es>2008-10-26 00:56:18 +0000
commitd2f4e5ea6e980e48c292f5ca250e99377e3ee111 (patch)
treefc3d3cd1740d207476000fe296b533218a3cc36f /lib/CMakeLists.txt
parent9a30c2474f824db655d0744856f8030ad377e339 (diff)
downloadclang-d2f4e5ea6e980e48c292f5ca250e99377e3ee111.tar.gz
CMake: Builds and installs clang binary and libs (no docs yet). It
must be under the `tools' subdirectory of the LLVM *source* tree. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@58180 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
new file mode 100644
index 0000000000..d2fafb3927
--- /dev/null
+++ b/lib/CMakeLists.txt
@@ -0,0 +1,10 @@
+add_subdirectory(Headers)
+add_subdirectory(Basic)
+add_subdirectory(Lex)
+add_subdirectory(Parse)
+add_subdirectory(AST)
+add_subdirectory(Sema)
+add_subdirectory(CodeGen)
+add_subdirectory(Analysis)
+add_subdirectory(Rewrite)
+add_subdirectory(Driver)