summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Collingbourne <peter@pcc.me.uk>2010-08-24 00:31:22 +0000
committerPeter Collingbourne <peter@pcc.me.uk>2010-08-24 00:31:22 +0000
commit1b7255de78c99ef2b8a06bb5261a3c776ac1db36 (patch)
treee7ae76a9670eaf107895ad8dc9eac0f1320d33e4 /lib/CMakeLists.txt
parentaaa107acc8f906203101af259e8d764b5027700a (diff)
downloadclang-1b7255de78c99ef2b8a06bb5261a3c776ac1db36.tar.gz
Move ExecuteCompilerInvocation to a new library FrontendTool
r110903 introduced a dependency from Frontend to every library that declared an Action by introducing Action references that previously resided in the driver in the file ExecuteCompilerInvocation.cpp. This patch moves ExecuteCompilerInvocation to a new library named FrontendTool which is intended to bear these dependencies. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@111873 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 8ecfcbea29..bd5e342e02 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -10,5 +10,6 @@ add_subdirectory(Rewrite)
add_subdirectory(Driver)
add_subdirectory(Serialization)
add_subdirectory(Frontend)
+add_subdirectory(FrontendTool)
add_subdirectory(Index)
add_subdirectory(Checker)