summaryrefslogtreecommitdiff
path: root/lib/AST/CMakeLists.txt
diff options
context:
space:
mode:
authorDeLesley Hutchins <delesley@google.com>2013-12-30 17:24:36 +0000
committerDeLesley Hutchins <delesley@google.com>2013-12-30 17:24:36 +0000
commit484c793a298f320d5e2c79e20a854be054199dff (patch)
tree4a3d4bebba636d741268f4fbadf7e659d6aedcfd /lib/AST/CMakeLists.txt
parent445938035707b9c4accb6234b8da706fd7861911 (diff)
downloadclang-484c793a298f320d5e2c79e20a854be054199dff.tar.gz
Update RecursiveASTVisitor so that it visits attributes. This is currently
important for thread safety attributes, which contain expressions that were not being visited, and were thus invisible to various tools. There are now Visit*Attr methods that can be overridden for every attribute. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@198224 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/AST/CMakeLists.txt')
-rw-r--r--lib/AST/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/AST/CMakeLists.txt b/lib/AST/CMakeLists.txt
index 461e8b3ac1..e0b3c33890 100644
--- a/lib/AST/CMakeLists.txt
+++ b/lib/AST/CMakeLists.txt
@@ -65,6 +65,7 @@ add_dependencies(clangAST
ClangAttrList
ClangAttrImpl
ClangAttrDump
+ ClangAttrVisitor
ClangCommentCommandInfo
ClangCommentCommandList
ClangCommentNodes