summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBruno Cardoso Lopes <bruno.cardoso@gmail.com>2018-06-20 21:16:37 +0000
committerBruno Cardoso Lopes <bruno.cardoso@gmail.com>2018-06-20 21:16:37 +0000
commitfcfa2dd517ec1a6045a81e8247e346d630a22618 (patch)
tree9258c3dff18a466f41387c895dac47881bc9f304 /CMakeLists.txt
parent443ea9f82a450eca95affcddefed86a5aec03618 (diff)
downloadclang-fcfa2dd517ec1a6045a81e8247e346d630a22618.tar.gz
Add python tool to dump and construct header maps
Header maps are binary files used by Xcode, which are used to map header names or paths to other locations. Clang has support for those since its inception, but there's not a lot of header map testing around. Since it's a binary format, testing becomes pretty much brittle and its hard to even know what's inside if you don't have the appropriate tools. Add a python based tool that allows creating and dumping header maps based on a json description of those. While here, rewrite tests to use the tool and remove the binary files from the tree. This tool was initially written by Daniel Dunbar. Differential Revision: https://reviews.llvm.org/D46485 rdar://problem/39994722 git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@335177 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ab81ec34b0..ae8835d751 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -753,6 +753,7 @@ endif()
if (LLVM_ADD_NATIVE_VISUALIZERS_TO_SOLUTION)
add_subdirectory(utils/ClangVisualizers)
endif()
+add_subdirectory(utils/hmaptool)
configure_file(
${CLANG_SOURCE_DIR}/include/clang/Config/config.h.cmake