summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorShoaib Meenai <smeenai@fb.com>2019-02-20 23:08:43 +0000
committerShoaib Meenai <smeenai@fb.com>2019-02-20 23:08:43 +0000
commite4455cea71c114b15ac657ef391053bda38d1b2f (patch)
tree2f9dcc2c82a9a604963c7de67df97de3899f28c5 /CMakeLists.txt
parent003a5a6ba21122a6437ec85f5f24f01c2989c4d7 (diff)
downloadclang-e4455cea71c114b15ac657ef391053bda38d1b2f.tar.gz
[clang] Switch to LLVM_ENABLE_IDE
r344555 switched LLVM to guarding install targets with LLVM_ENABLE_IDE instead of CMAKE_CONFIGURATION_TYPES, which expresses the intent more directly and can be overridden by a user. Make the corresponding change in clang. LLVM_ENABLE_IDE is computed by HandleLLVMOptions, so it should be available for both standalone and integrated builds. Differential Revision: https://reviews.llvm.org/D58284 git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@354525 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f74837c1ae..8d43ec90e1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -552,7 +552,7 @@ endif()
add_custom_target(clang-libraries)
set_target_properties(clang-libraries PROPERTIES FOLDER "Misc")
-if(NOT CMAKE_CONFIGURATION_TYPES)
+if(NOT LLVM_ENABLE_IDE)
add_llvm_install_targets(install-clang-libraries
DEPENDS clang-libraries
COMPONENT clang-libraries)
@@ -563,7 +563,7 @@ if(CLANG_LIBS)
list(REMOVE_DUPLICATES CLANG_LIBS)
foreach(lib ${CLANG_LIBS})
add_dependencies(clang-libraries ${lib})
- if(NOT CMAKE_CONFIGURATION_TYPES)
+ if(NOT LLVM_ENABLE_IDE)
add_dependencies(install-clang-libraries install-${lib})
endif()
endforeach()