summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2018-08-30 23:41:03 +0000
committerStephen Kelly <steveire@gmail.com>2018-08-30 23:41:03 +0000
commitcfc1004a85a3d32955bc84160714ec14d6381af9 (patch)
treea53a485421ab6595f81fb931810bf17f05f4c03d /CMakeLists.txt
parente6e8fef281d155094fae889cd0c9b7a5830f496b (diff)
downloadclang-cfc1004a85a3d32955bc84160714ec14d6381af9.tar.gz
Remove vestiges of configure buildsystem
Summary: Subscribers: mgorny, cfe-commits Differential Revision: https://reviews.llvm.org/D50738 git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@341146 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 2 insertions, 14 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7e2762b6d5..61fd913a2a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -289,25 +289,13 @@ set(CLANG_SOURCE_DIR ${CMAKE_CURRENT_SOURCE_DIR})
set(CLANG_BINARY_DIR ${CMAKE_CURRENT_BINARY_DIR})
if( CMAKE_SOURCE_DIR STREQUAL CMAKE_BINARY_DIR AND NOT MSVC_IDE )
- message(FATAL_ERROR "In-source builds are not allowed. CMake would overwrite "
-"the makefiles distributed with LLVM. Please create a directory and run cmake "
+ message(FATAL_ERROR "In-source builds are not allowed. "
+"Please create a directory and run cmake "
"from there, passing the path to this source directory as the last argument. "
"This process created the file `CMakeCache.txt' and the directory "
"`CMakeFiles'. Please delete them.")
endif()
-if( NOT CMAKE_SOURCE_DIR STREQUAL CMAKE_BINARY_DIR )
- file(GLOB_RECURSE
- tablegenned_files_on_include_dir
- "${CLANG_SOURCE_DIR}/include/clang/*.inc")
- if( tablegenned_files_on_include_dir )
- message(FATAL_ERROR "Apparently there is a previous in-source build, "
-"probably as the result of running `configure' and `make' on "
-"${CLANG_SOURCE_DIR}. This may cause problems. The suspicious files are:\n"
-"${tablegenned_files_on_include_dir}\nPlease clean the source directory.")
- endif()
-endif()
-
# If CLANG_VERSION_* is specified, use it, if not use LLVM_VERSION_*.
if(NOT DEFINED CLANG_VERSION_MAJOR)
set(CLANG_VERSION_MAJOR ${LLVM_VERSION_MAJOR})