summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBenjamin Kramer <benny.kra@googlemail.com>2009-10-11 12:22:00 +0000
committerBenjamin Kramer <benny.kra@googlemail.com>2009-10-11 12:22:00 +0000
commitbd785546c9cdaf55f6f3f905292755f749f77fc5 (patch)
tree46b8a2145fa8da343c877517dd97ad88bd9e3f3b /CMakeLists.txt
parente094fe82787430db7e2e494989c40e601d50d2cb (diff)
downloadclang-bd785546c9cdaf55f6f3f905292755f749f77fc5.tar.gz
CMake mingw build fixes.
- llvm's libs must be linked after clang's - libLLVMSystem depends on psapi on win32 (get_system_libs has it) - CIndex builds successfully on mingw now git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@83773 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cdc2b9b8a4..0cd52d0d94 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -43,14 +43,18 @@ macro(add_clang_library name)
if( LLVM_COMMON_DEPENDS )
add_dependencies( ${name} ${LLVM_COMMON_DEPENDS} )
endif( LLVM_COMMON_DEPENDS )
- if( LLVM_LINK_COMPONENTS )
- llvm_config(${name} ${LLVM_LINK_COMPONENTS})
- endif( LLVM_LINK_COMPONENTS )
if( LLVM_USED_LIBS )
foreach(lib ${LLVM_USED_LIBS})
target_link_libraries( ${name} ${lib} )
endforeach(lib)
endif( LLVM_USED_LIBS )
+ if( LLVM_LINK_COMPONENTS )
+ llvm_config(${name} ${LLVM_LINK_COMPONENTS})
+ endif( LLVM_LINK_COMPONENTS )
+ get_system_libs(llvm_system_libs)
+ if( llvm_system_libs )
+ target_link_libraries(${name} ${llvm_system_libs})
+ endif( llvm_system_libs )
add_dependencies(${name} ClangDiagnosticCommon)
if(MSVC)
get_target_property(cflag ${name} COMPILE_FLAGS)