summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSylvestre Ledru <sylvestre@debian.org>2018-03-29 10:05:46 +0000
committerSylvestre Ledru <sylvestre@debian.org>2018-03-29 10:05:46 +0000
commitbb1812b73ee532a2466cc7044820f4d23484dcf8 (patch)
tree8cc127ca3f827c367b1630372486c6e647062de9 /CMakeLists.txt
parenta04c82fd35ceac9da931f730b9682718157dcd49 (diff)
downloadclang-bb1812b73ee532a2466cc7044820f4d23484dcf8.tar.gz
Rename clang link from clang-X.Y to clang-X
Summary: As we are only doing X.0.Z releases (not using the minor version), there is no need to keep -X.Y in the version. So, instead, I propose the following: Instead of having clang-7.0 in bin/, we will have clang-7 Since also matches was gcc is doing. Reviewers: tstellar, dlj, dim, hans Reviewed By: dim, hans Subscribers: dim, mgorny, cfe-commits Differential Revision: https://reviews.llvm.org/D41808 git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@328769 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3bf3cfdf33..0aec29960e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -424,11 +424,11 @@ endif()
# Clang version information
set(CLANG_EXECUTABLE_VERSION
- "${CLANG_VERSION_MAJOR}.${CLANG_VERSION_MINOR}" CACHE STRING
- "Version number that will be placed into the clang executable, in the form XX.YY")
+ "${CLANG_VERSION_MAJOR}" CACHE STRING
+ "Major version number that will be appended to the clang executable name")
set(LIBCLANG_LIBRARY_VERSION
- "${CLANG_VERSION_MAJOR}.${CLANG_VERSION_MINOR}" CACHE STRING
- "Version number that will be placed into the libclang library , in the form XX.YY")
+ "${CLANG_VERSION_MAJOR}" CACHE STRING
+ "Major version number that will be appended to the libclang library")
mark_as_advanced(CLANG_EXECUTABLE_VERSION LIBCLANG_LIBRARY_VERSION)
option(CLANG_INCLUDE_TESTS