summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichal Gorny <mgorny@gentoo.org>2019-10-07 18:14:56 +0000
committerMichal Gorny <mgorny@gentoo.org>2019-10-07 18:14:56 +0000
commitb886fe4cb63a677a7ac7a75ee5d2282247b99301 (patch)
treeebe75f593d1d3e8484ec30012df61cf2f7a7c57d /CMakeLists.txt
parent0e6f1764e3d92afd7215c2cddcc09b3a39cc0a1c (diff)
downloadclang-b886fe4cb63a677a7ac7a75ee5d2282247b99301.tar.gz
[clang] [cmake] Support LLVM_DISTRIBUTION_COMPONENTS in stand-alone build
Differential Revision: https://reviews.llvm.org/D68412 git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@373936 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index aa21329365..45d2431a74 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -114,6 +114,7 @@ if( CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR )
include(TableGen)
include(HandleLLVMOptions)
include(VersionFromVCS)
+ include(LLVMDistributionSupport)
set(PACKAGE_VERSION "${LLVM_PACKAGE_VERSION}")
@@ -858,6 +859,10 @@ if (LLVM_ADD_NATIVE_VISUALIZERS_TO_SOLUTION)
endif()
add_subdirectory(utils/hmaptool)
+if(CLANG_BUILT_STANDALONE)
+ llvm_distribution_add_targets()
+endif()
+
configure_file(
${CLANG_SOURCE_DIR}/include/clang/Config/config.h.cmake
${CLANG_BINARY_DIR}/include/clang/Config/config.h)