summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Hosek <phosek@chromium.org>2017-11-29 00:34:46 +0000
committerPetr Hosek <phosek@chromium.org>2017-11-29 00:34:46 +0000
commitb4b0ed79ba80d83503c86ebff68ab02b14faba77 (patch)
treec867824e02360518c0ca6a8f95aee29a6bc0bfdf /CMakeLists.txt
parent41e14356676acdc8d9308be21315ccd6a729fc91 (diff)
downloadclang-b4b0ed79ba80d83503c86ebff68ab02b14faba77.tar.gz
[CMake] Support side-by-side checkouts in multi-stage build
Passthrough LLVM_ENABLE_{PROJECTS,RUNTIMES} to followup stages to support the side-by-side checkouts (aka monorepo layout). Differential Revision: https://reviews.llvm.org/D40258 git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@319267 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dac32b9cdd..e27a718e41 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -603,7 +603,9 @@ if (CLANG_ENABLE_BOOTSTRAP)
LLVM_BINUTILS_INCDIR
CLANG_REPOSITORY_STRING
CMAKE_MAKE_PROGRAM
- CMAKE_OSX_ARCHITECTURES)
+ CMAKE_OSX_ARCHITECTURES
+ LLVM_ENABLE_PROJECTS
+ LLVM_ENABLE_RUNTIMES)
# We don't need to depend on compiler-rt if we're building instrumented
# because the next stage will use the same compiler used to build this stage.