summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEvandro Menezes <e.menezes@samsung.com>2019-03-25 16:38:48 +0000
committerEvandro Menezes <e.menezes@samsung.com>2019-03-25 16:38:48 +0000
commita24f0488377773a35bfc27e25a4f8ed01c9fe2b3 (patch)
treef66f53e9671b1bf4c15b0b45d5ca3f08d1d13039 /CMakeLists.txt
parent34b404d309a8610fe2729fe9a98f564486f3673c (diff)
downloadclang-a24f0488377773a35bfc27e25a4f8ed01c9fe2b3.tar.gz
[clang] Remove cmake warning message (NFC)
Recognize an empty string for CLANG_DEFAULT_UNWINDLIB as a valid option. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@356920 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 39d8750cc2..4b26b288a7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -276,7 +276,8 @@ if (CLANG_DEFAULT_UNWINDLIB STREQUAL "")
endif()
endif()
-if (NOT(CLANG_DEFAULT_UNWINDLIB STREQUAL "none" OR
+if (NOT(CLANG_DEFAULT_UNWINDLIB STREQUAL "" OR
+ CLANG_DEFAULT_UNWINDLIB STREQUAL "none" OR
CLANG_DEFAULT_UNWINDLIB STREQUAL "libgcc" OR
CLANG_DEFAULT_UNWINDLIB STREQUAL "libunwind"))
message(WARNING "Resetting default unwindlib to use platform default")