summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorShoaib Meenai <smeenai@fb.com>2018-11-08 00:29:33 +0000
committerShoaib Meenai <smeenai@fb.com>2018-11-08 00:29:33 +0000
commit7668d4626c27696d1d5e4b2086b5882196fb4d68 (patch)
tree662fd8c357ec5b44806364a9b230e02573a14395 /CMakeLists.txt
parent0ccf2f537d5fbd909a757be4bbb0cdb6d325d048 (diff)
downloadclang-7668d4626c27696d1d5e4b2086b5882196fb4d68.tar.gz
[clang] Set CMP0075 to new
Make the check_include_file* macros honor CMAKE_REQUIRED_LIBRARIES. This shouldn't cause any of the configuration checks to give different results, and I verified that a clean configure before and after this change resulted in identical CMake caches on my machine. The same change was done for LLVM in r346377. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@346378 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3f5c3ae2ac..0a0f885b2b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,9 @@
cmake_minimum_required(VERSION 3.4.3)
+if(POLICY CMP0075)
+ cmake_policy(SET CMP0075 NEW)
+endif()
+
# If we are not building as a part of LLVM, build Clang as an
# standalone project, using LLVM as an external library:
if( CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR )