summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlp Toker <alp@nuanti.com>2014-06-06 05:01:47 +0000
committerAlp Toker <alp@nuanti.com>2014-06-06 05:01:47 +0000
commit6e650a52d12a356ff58a79e43d82588e8c64a378 (patch)
treec2c0a7048351a1138008d5f72bd355073b8c3504 /CMakeLists.txt
parent5db2c779a8a3817ffd7bee2f7cbcd4ca7e324611 (diff)
downloadclang-6e650a52d12a356ff58a79e43d82588e8c64a378.tar.gz
Always check for libxml2 in CMake
This is clang's business and LLVM will soon be updated not to perform the check for us. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@210308 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2d7bb6f540..ece6bf8bce 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -156,11 +156,11 @@ if( CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR )
endif()
set( CLANG_BUILT_STANDALONE 1 )
+endif()
- find_package(LibXml2)
- if (LIBXML2_FOUND)
- set(CLANG_HAVE_LIBXML 1)
- endif ()
+find_package(LibXml2)
+if (LIBXML2_FOUND)
+ set(CLANG_HAVE_LIBXML 1)
endif()
set(CLANG_RESOURCE_DIR "" CACHE STRING