summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Kratochvil <jan.kratochvil@redhat.com>2018-11-18 09:36:36 +0000
committerJan Kratochvil <jan.kratochvil@redhat.com>2018-11-18 09:36:36 +0000
commit6c59a8e68d93b90a77951a24724782f584bfebbd (patch)
treeb9a9e2957205e265fbc12d71261a5d0902511c66 /CMakeLists.txt
parent4478cc1b78174a29430da5419cef6881298e1491 (diff)
downloadclang-6c59a8e68d93b90a77951a24724782f584bfebbd.tar.gz
cmake: z3: Remove EXACT from 4.7.1 after being compatible with 4.8.1
After check-in of D54391 a comment there by @mikhail.ramalho says: Since we're supporting version 4.8.1 now, the cmake file should be changed to "minimum" instead of "exact". Differential Revision: https://reviews.llvm.org/D54535 git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@347152 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1482b17abc..9af43440b4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -410,7 +410,7 @@ option(CLANG_ENABLE_STATIC_ANALYZER "Build static analyzer." ON)
set(CLANG_ANALYZER_Z3_INSTALL_DIR "" CACHE STRING "Install directory of the Z3 solver.")
-find_package(Z3 4.7.1 EXACT)
+find_package(Z3 4.7.1)
if (CLANG_ANALYZER_Z3_INSTALL_DIR)
if (NOT Z3_FOUND)