summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Hosek <phosek@chromium.org>2018-06-11 20:59:31 +0000
committerPetr Hosek <phosek@chromium.org>2018-06-11 20:59:31 +0000
commit62a3eb3a5ba23f34b10c90509f6ddec024fddfd6 (patch)
treef1370f3177fa30a48ec80aec71ba0ec63399903b /CMakeLists.txt
parent93dd9971068cb0d60f866f621f9f828a6b2fdce9 (diff)
downloadclang-62a3eb3a5ba23f34b10c90509f6ddec024fddfd6.tar.gz
[CMake] Allow specifying extra dependencies of bootstrap stage
This allows adding additional bootstrap dependencies to the bootstrap compiler that may be needed by later stages. Differential Revision: https://reviews.llvm.org/D47355 git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@334437 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fc7a3889a7..ab81ec34b0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -583,6 +583,10 @@ if (CLANG_ENABLE_BOOTSTRAP)
endif()
endif()
+ if(CLANG_BOOTSTRAP_EXTRA_DEPS)
+ add_dependencies(clang-bootstrap-deps ${CLANG_BOOTSTRAP_EXTRA_DEPS})
+ endif()
+
add_custom_target(${NEXT_CLANG_STAGE}-clear
DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/${NEXT_CLANG_STAGE}-cleared
)