summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichal Gorny <mgorny@gentoo.org>2018-10-11 11:58:14 +0000
committerMichal Gorny <mgorny@gentoo.org>2018-10-11 11:58:14 +0000
commit0f0140520db5ffd69ce824e68230550f92e96f62 (patch)
tree48a7be004430a68157c90503c99351f851d12ead /CMakeLists.txt
parent517f6f4f9eb1d3e7826dbdd0cee55cf023cd6dc0 (diff)
downloadclang-0f0140520db5ffd69ce824e68230550f92e96f62.tar.gz
[tests] Include Python binding tests in CMake rules
Add a new CMake rule check-clang-python to run the Python bindings' test suite, and include it in check-all. Differential Revision: https://reviews.llvm.org/D52840 git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@344241 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 61fd913a2a..84984f75b5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -502,6 +502,7 @@ if( CLANG_INCLUDE_TESTS )
)
endif()
add_subdirectory(utils/perf-training)
+ add_subdirectory(bindings/python/tests)
endif()
option(CLANG_INCLUDE_DOCS "Generate build targets for the Clang docs."