summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2019-11-06 15:42:56 -0800
committerGitHub <noreply@github.com>2019-11-06 15:42:56 -0800
commit826585447c8179e438ab27b2df86dbb6ecf5e4a3 (patch)
tree08d6b4c3eafc1cd51bc691dadb7c1c786d83d58b /setup.py
parent930fd6724aa68f8685c9c3ec1847fb7c1091c681 (diff)
parent264e615d357cda772943badf98d25ce0677ad2f2 (diff)
downloadcherrypy-git-826585447c8179e438ab27b2df86dbb6ecf5e4a3.tar.gz
Merge pull request #1743 from cherrypy/feature/pytest-services-on-windows
Rely on pytest-services 2.0 for Windows compatibility
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 1 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index ad211f58..a1d777e5 100755
--- a/setup.py
+++ b/setup.py
@@ -87,9 +87,7 @@ params = dict(
'backports.unittest_mock',
'path.py',
'requests_toolbelt',
- ],
- 'testing:sys_platform != "win32"': [
- 'pytest-services',
+ 'pytest-services>=2',
],
# Enables memcached session support via `cherrypy[memcached_session]`:
'memcached_session': ['python-memcached>=1.58'],