summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2017-07-08 14:16:57 -0400
committerJason R. Coombs <jaraco@jaraco.com>2017-07-08 14:16:57 -0400
commit5af46f1848d9a5c60c6b2978f31309b2b81ba697 (patch)
tree662be6c63926246a0606f335b2a34ee60eecb40a /setup.py
parent705eea14aacb2586d748d96d16ed701cdb95d126 (diff)
downloadcherrypy-git-5af46f1848d9a5c60c6b2978f31309b2b81ba697.tar.gz
Drop support for Python 2.6. Fixes #1607.v11.0.0
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 1 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 701d0d86..2b9f18a4 100755
--- a/setup.py
+++ b/setup.py
@@ -30,7 +30,6 @@ classifiers = [
'License :: OSI Approved :: BSD License',
'Programming Language :: Python',
'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.1',
@@ -84,9 +83,6 @@ extras_require = {
# cherrypy.lib.gctools
'objgraph',
- # graphviz, required by objgraph, dropped support for Python 2.6
- # in 0.6
- 'graphviz<0.6; python_version == "2.6"',
'pytest>=2.8',
'pytest-sugar',
@@ -123,7 +119,7 @@ setup_params = dict(
setup_requires=[
'setuptools_scm',
] + pytest_runner,
- python_requires='>=2.6,!=3.0.*',
+ python_requires='>=2.7,!=3.0.*',
)