summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2018-07-10 11:27:01 -0400
committerJason R. Coombs <jaraco@jaraco.com>2018-07-10 11:27:01 -0400
commit249661104aab71a7327bb8adad970378c29d3dd9 (patch)
tree1015275989d7f7fb7ac13a74d8bd2bf6f189409e /setup.py
parent03cf03b7ea65a5f088fad0c24a71d4d81caf2de5 (diff)
downloadcherrypy-git-249661104aab71a7327bb8adad970378c29d3dd9.tar.gz
Pin against tempora 1.13 to avoid inclusion of namespace package. Fixes #1722.v16.0.3
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 5720465f..8ba0421e 100755
--- a/setup.py
+++ b/setup.py
@@ -61,6 +61,9 @@ install_requires = [
'six>=1.11.0',
'cheroot>=6.2.4',
'portend>=2.1.1',
+
+ # temporary workaround for #1722
+ 'tempora<1.13',
]
extras_require = {
@@ -87,6 +90,7 @@ extras_require = {
'backports.unittest_mock',
'path.py',
'requests_toolbelt',
+ 'jaraco.packaging',
],
# Enables memcached session support via `cherrypy[memcached_session]`:
'memcached_session': ['python-memcached>=1.58'],