summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rw-r--r--debian/postrm4
2 files changed, 10 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 609ddd6..575fb00 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+ca-certificates (20090709) unstable; urgency=low
+
+ * Fix purge by checking for `/etc/ssl/certs' first. (Closes: #536331)
+
+ -- Philipp Kern <pkern@debian.org> Thu, 09 Jul 2009 10:35:39 +0200
+
ca-certificates (20090708) unstable; urgency=low
* Removed CA files:
diff --git a/debian/postrm b/debian/postrm
index ae65ee5..a397de9 100644
--- a/debian/postrm
+++ b/debian/postrm
@@ -17,6 +17,10 @@ set -e
# for details, see /usr/share/doc/packaging-manual/
remove_dangling_symlinks() {
+ if ! [ -d /etc/ssl/certs ]
+ then
+ return
+ fi
echo -n "Removing dangling symlinks from /etc/ssl/certs... "
find /etc/ssl/certs -type l -print | while read h
do