summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJürg Billeter <j@bitron.ch>2018-08-07 16:13:54 +0200
committerJürg Billeter <j@bitron.ch>2018-08-07 15:36:35 +0000
commiteee4b674f719cde301c9bcf108c0d7477337308a (patch)
treedb4195f3b49089aefcb7b797aa8a02fba3b6b838 /setup.py
parent2ceb5dec5848354ecec88cdae915a3231387c086 (diff)
downloadbuildstream-eee4b674f719cde301c9bcf108c0d7477337308a.tar.gz
Revert "Restrict version of pylint"
This reverts commit 4f168b9b6a02216e2fae24d758ae6b778e545869. The latest version of pytest_pylint works fine with pylint 2, which means there is no longer a reason to restrict the pylint version. pylint 2 is required for Python 3.7.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 0be02dfa1..efa4ebc1e 100755
--- a/setup.py
+++ b/setup.py
@@ -272,6 +272,5 @@ setup(name='BuildStream',
'pytest-cov >= 2.5.0',
# Provide option to run tests in parallel, less reliable
'pytest-xdist',
- 'pytest >= 3.1.0',
- 'pylint >= 1.8 , < 2'],
+ 'pytest >= 3.1.0'],
zip_safe=False)