summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBenjamin Schubert <ben.c.schubert@gmail.com>2019-05-21 11:52:51 +0100
committerBenjamin Schubert <contact@benschubert.me>2019-05-29 19:50:18 +0100
commiteadcca3eaa921341b6c29d48c841614d9da7472a (patch)
tree112bfb4ad12dade267d7b445df4fa8c490d7bc9e /setup.py
parent6901a829027a1fe0dd2002852a80a2eef0b322e4 (diff)
downloadbuildstream-eadcca3eaa921341b6c29d48c841614d9da7472a.tar.gz
_variable: Import _yaml from C.
This requires the addition of a definition file (.pxd), to list symbols exported.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index b848e2458..a57e65b56 100755
--- a/setup.py
+++ b/setup.py
@@ -392,7 +392,7 @@ def register_cython_module(module_name, dependencies=None):
BUILD_EXTENSIONS = []
register_cython_module("buildstream._yaml")
-register_cython_module("buildstream._variables")
+register_cython_module("buildstream._variables", dependencies=["buildstream._yaml"])
#####################################################
# Main setup() Invocation #