summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBenjamin Schubert <ben.c.schubert@gmail.com>2019-07-15 17:30:59 +0100
committerbst-marge-bot <marge-bot@buildstream.build>2019-07-17 09:04:08 +0000
commite8ddeef1ce55076a08106f4b4ffb074618f66b19 (patch)
treedfe55e5b1ae0dbd62f2b883d38df2a3ae8aa9f84 /setup.py
parentef7bf9ddae536221589f52654fb7e2aed1319cd6 (diff)
downloadbuildstream-e8ddeef1ce55076a08106f4b4ffb074618f66b19.tar.gz
utils: Extract 'url_directory_name' to a cython module
`url_directory_name` is heavily called from any downloadable source plugin, and moving it to cython gives a more than 10x speedup
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 1ea423e1a..284e74d7f 100755
--- a/setup.py
+++ b/setup.py
@@ -406,6 +406,7 @@ register_cython_module("buildstream.node")
register_cython_module("buildstream._loader._loader")
register_cython_module("buildstream._loader.types", dependencies=["buildstream.node"])
register_cython_module("buildstream._yaml", dependencies=["buildstream.node"])
+register_cython_module("buildstream._utils")
register_cython_module("buildstream._variables", dependencies=["buildstream.node"])
#####################################################