summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBenjamin Schubert <contact@benschubert.me>2020-05-07 17:40:51 +0100
committerBenjamin Schubert <contact@benschubert.me>2020-05-07 17:40:51 +0100
commitda5b798b8c75cdc2875abb800f6189e8b3f7ab28 (patch)
treece0b884cc57ba07295b5929e14033aa9a23e3258 /setup.py
parentceedc4819589ea8895ef356d0276bcc2985b9408 (diff)
downloadbuildstream-da5b798b8c75cdc2875abb800f6189e8b3f7ab28.tar.gz
setup.py: Also run pylint on this file
Also fix the various errors in the file
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 2 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index ac6ba21fb..a92c19221 100755
--- a/setup.py
+++ b/setup.py
@@ -22,13 +22,11 @@
import os
from pathlib import Path
import re
-import shutil
-import subprocess
import sys
# Add local directory to the path, in order to be able to import versioneer
sys.path.append(os.path.dirname(__file__))
-import versioneer # noqa
+import versioneer # pylint: disable=wrong-import-position
##################################################################
@@ -168,7 +166,7 @@ class BuildGRPC(Command):
except ImportError:
print("BuildStream requires grpc_tools in order to build gRPC modules.\n"
"Install it via pip (pip3 install grpcio-tools).")
- exit(1)
+ sys.exit(1)
protos_root = 'src/buildstream/_protos'