summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBenjamin Schubert <contact@benschubert.me>2019-05-18 14:01:08 +0100
committerBenjamin Schubert <contact@benschubert.me>2019-05-29 19:47:57 +0100
commitd220c4c3bcf31b9d4660a6e915e70269c891bd9f (patch)
tree249c9a16fe33a7af41b71e035abbbbee0268daba /setup.py
parent7c9004b0d2836f8c2349f13f9e3d4bdc1eb6b8ed (diff)
downloadbuildstream-d220c4c3bcf31b9d4660a6e915e70269c891bd9f.tar.gz
Introduce pyproject.toml
Using pyproject.toml, defined in PEP518, allows us to have an isolated build environment, ensuring that Cython can be installed before calling setup.py in tox. This allows us to use cython helpers in the setup.py script. This is a prerequisite for introducing Cython in the codebase
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 267ca6fb4..0caf7bae9 100755
--- a/setup.py
+++ b/setup.py
@@ -19,13 +19,15 @@
# Tristan Van Berkom <tristan.vanberkom@codethink.co.uk>
import os
+from pathlib import Path
import re
import shutil
import subprocess
import sys
-import versioneer
-from pathlib import Path
+# Add local directory to the path, in order to be able to import versioneer
+sys.path.append(os.path.dirname(__file__))
+import versioneer # noqa
##################################################################