summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBenjamin Schubert <contact@benschubert.me>2019-06-05 21:09:53 +0100
committerbst-marge-bot <marge-bot@buildstream.build>2019-06-06 15:53:43 +0000
commitbaec142e623f9e8a4efd93183ac2f7ef15d84b06 (patch)
tree1c20ed5671fd4b139cbc71afee441ee575d9ba00 /setup.py
parent6a42630a4057e704ed00fe8d478c86f774c6fd3c (diff)
downloadbuildstream-baec142e623f9e8a4efd93183ac2f7ef15d84b06.tar.gz
_loader/types: move to a cython package
Types is a simple module that accounts for a few percent of a basic 'show' operation. Having it cythonized allows us to get better performance without too much wokr
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index e68dc383c..e393096b8 100755
--- a/setup.py
+++ b/setup.py
@@ -399,6 +399,7 @@ def register_cython_module(module_name, dependencies=None):
BUILD_EXTENSIONS = []
register_cython_module("buildstream._loader._loader")
+register_cython_module("buildstream._loader.types")
register_cython_module("buildstream._yaml")
register_cython_module("buildstream._variables", dependencies=["buildstream._yaml"])