summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBenjamin Schubert <ben.c.schubert@gmail.com>2019-05-17 18:47:27 +0100
committerBenjamin Schubert <contact@benschubert.me>2019-05-29 19:47:57 +0100
commita5a16bee862f7e552a4a8dbd75ff10db7b9c1342 (patch)
treecbb075fcaf585e9741fee1d3df25e4017e743d8e /setup.py
parentf5ee7679b0b9b469dacc25f71dc46fa788367a1b (diff)
downloadbuildstream-a5a16bee862f7e552a4a8dbd75ff10db7b9c1342.tar.gz
_yaml: Cythonize and internalize Node
Node used to be a NamedTuple that we used to access by index for speed reasons. Moving to an extension class allows us to access attributes by name, making the code easier to read and less error prone. Moreover, we do gain speed and memory by doing this move. Also fix a few places where we would not have an entire `Node` object but were instead just returning a tuple, missing some entries.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 90aa74d31..b848e2458 100755
--- a/setup.py
+++ b/setup.py
@@ -391,6 +391,7 @@ def register_cython_module(module_name, dependencies=None):
BUILD_EXTENSIONS = []
+register_cython_module("buildstream._yaml")
register_cython_module("buildstream._variables")
#####################################################