summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBenjamin Schubert <contact@benschubert.me>2019-07-26 14:47:08 +0100
committerBenjamin Schubert <contact@benschubert.me>2019-07-29 10:42:02 +0100
commit90da23867767905c39bf8199c2b8a4d6e13a5c95 (patch)
tree44f658016a1176a7985681421cc76fbcc671a323 /setup.py
parent7736e44adb29688c13da1f4c5bddf03bd878a0f3 (diff)
downloadbuildstream-90da23867767905c39bf8199c2b8a4d6e13a5c95.tar.gz
types: Add a 'FastEnum' implementation and replace Enum by it
'Enum' has a big performance impact on the running code. Replacing it with a safe subset of functionality removes lots of this overhead without removing the benefits of using enums (safe comparisions, uniqueness)
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 141fb0539..19779fb69 100755
--- a/setup.py
+++ b/setup.py
@@ -407,6 +407,7 @@ register_cython_module("buildstream._loader._loader")
register_cython_module("buildstream._loader.loadelement")
register_cython_module("buildstream._loader.types", dependencies=["buildstream.node"])
register_cython_module("buildstream._yaml", dependencies=["buildstream.node"])
+register_cython_module("buildstream._types")
register_cython_module("buildstream._utils")
register_cython_module("buildstream._variables", dependencies=["buildstream.node"])