summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChandan Singh <chandan@chandansingh.net>2019-12-06 15:14:32 +0000
committerChandan Singh <chandan@chandansingh.net>2019-12-23 09:33:21 +0000
commit8a9e3cb9f71e3cac683af1ff667e4de8ef802132 (patch)
tree490267b4aca938f21afedbcdb6c1da14bd8ad709 /setup.py
parentbb93d63fd9a081eef14c20bec818d60084d065c3 (diff)
downloadbuildstream-8a9e3cb9f71e3cac683af1ff667e4de8ef802132.tar.gz
Drop support for `setup.py test`
Drop support for running tests via `setup.py test`, that is considered deprecated. `tox` is our primary frontend for running tests, so this change ensures that we don't have to support multiple ways of running tests. For testing against a specific installation environment, `tox` is not quite practical. But in these cases, one can run `pytest` directly. So, there is no need for this additional indirection. This was discussed in the following mailing list thread: https://mail.gnome.org/archives/buildstream-list/2019-December/msg00006.html.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py44
1 files changed, 0 insertions, 44 deletions
diff --git a/setup.py b/setup.py
index 19779fb69..7c546e798 100755
--- a/setup.py
+++ b/setup.py
@@ -44,7 +44,6 @@ if sys.version_info[0] != REQUIRED_PYTHON_MAJOR or sys.version_info[1] < REQUIRE
try:
from setuptools import setup, find_packages, Command, Extension
from setuptools.command.easy_install import ScriptWriter
- from setuptools.command.test import test as TestCommand
except ImportError:
print("BuildStream requires setuptools in order to build. Install it using"
" your package manager (usually python3-setuptools) or via pip (pip3"
@@ -245,48 +244,9 @@ class BuildGRPC(Command):
f.write(code)
-#####################################################
-# Pytest command #
-#####################################################
-class PyTest(TestCommand):
- """Defines a pytest command class to run tests from setup.py"""
-
- user_options = TestCommand.user_options + [
- ("addopts=", None, "Arguments to pass to pytest"),
- ('index-url=', None, "Specify an index url from which to retrieve "
- "dependencies"),
- ]
-
- # pylint: disable=attribute-defined-outside-init
- def initialize_options(self):
- super().initialize_options()
- self.addopts = ""
- self.index_url = None
-
- def run(self):
- if self.index_url is not None:
- if self.distribution.command_options.get("easy_install") is None:
- self.distribution.command_options["easy_install"] = {}
-
- self.distribution.command_options["easy_install"]["index_url"] = (
- "cmdline", self.index_url,
- )
- super().run()
-
- def run_tests(self):
- import shlex
- import pytest
-
- errno = pytest.main(shlex.split(self.addopts))
-
- if errno:
- raise SystemExit(errno)
-
-
def get_cmdclass():
cmdclass = {
'build_grpc': BuildGRPC,
- 'pytest': PyTest,
}
cmdclass.update(versioneer.get_cmdclass())
return cmdclass
@@ -295,9 +255,6 @@ def get_cmdclass():
#####################################################
# Gather requirements #
#####################################################
-with open('requirements/dev-requirements.in') as dev_reqs:
- dev_requires = dev_reqs.read().splitlines()
-
with open('requirements/requirements.in') as install_reqs:
install_requires = install_reqs.read().splitlines()
@@ -468,7 +425,6 @@ setup(name='BuildStream',
],
install_requires=install_requires,
entry_points=bst_install_entry_points,
- tests_require=dev_requires,
ext_modules=cythonize(
BUILD_EXTENSIONS,
compiler_directives={