summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTristan Van Berkom <tristan.vanberkom@codethink.co.uk>2017-04-08 17:25:20 +0900
committerTristan Van Berkom <tristan.vanberkom@codethink.co.uk>2017-04-08 17:25:20 +0900
commit8582534b5477d86128ba5c22086c76bb9b968932 (patch)
tree1896c9666efd5f68bfa6469b2846f487cd5c5f7f /setup.py
parentd939920cd436e7014bbc8986a2b75f0053f0576e (diff)
downloadbuildstream-8582534b5477d86128ba5c22086c76bb9b968932.tar.gz
setup.py: BuildStream now depends on python 3.4
It was now tested on 3.4, after a few changes it seems to work well with 3.4, backing down the version requirement as 3.4 is more widely available in today's distros.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 7160786ce..d932b4ed8 100755
--- a/setup.py
+++ b/setup.py
@@ -22,8 +22,8 @@ import os
import shutil
import sys
-if sys.version_info[0] != 3 or sys.version_info[1] < 5:
- print("BuildStream requires Python >= 3.5")
+if sys.version_info[0] != 3 or sys.version_info[1] < 4:
+ print("BuildStream requires Python >= 3.4")
sys.exit(1)
bwrap_path = shutil.which('bwrap')