summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorValentin David <valentin.david@codethink.co.uk>2018-08-13 12:09:45 +0200
committerValentin David <valentin.david@gmail.com>2018-08-13 12:39:23 +0000
commit6e759d8aa41f60e9a0dfe409e61e2c32a7a1d386 (patch)
treefdc7d0c987d5fcbcdf75597928e07b8019036b28 /setup.py
parent5a66710733fcb0d3e24da9ba935de56b79bdb4c5 (diff)
downloadbuildstream-6e759d8aa41f60e9a0dfe409e61e2c32a7a1d386.tar.gz
Set version of ruaml.yaml to strictly less than 0.15.52.
This allows to use version 0.15.51 rather than 0.15.0 which is required for Python 3. Fixes #571.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 35b8245c9..cda0ebbcb 100755
--- a/setup.py
+++ b/setup.py
@@ -258,7 +258,7 @@ setup(name='BuildStream',
install_requires=[
'setuptools',
'psutil',
- 'ruamel.yaml <= 0.15',
+ 'ruamel.yaml < 0.15.52',
'pluginbase',
'Click',
'blessings',