summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChandan Singh <csingh43@bloomberg.net>2018-12-07 17:36:00 +0000
committerChandan Singh <csingh43@bloomberg.net>2018-12-14 19:34:20 +0000
commit629a6e52410f97edb386e59c48b7a7c28b3bf30a (patch)
tree43cb5c3c94db5a6bb014d5f61a49c0b571caf6f6 /setup.py
parent13eb7ed2f356e1f42a8d379e313d55c5d3875d34 (diff)
downloadbuildstream-629a6e52410f97edb386e59c48b7a7c28b3bf30a.tar.gz
Introduce new "source" command group
Following the message thread https://mail.gnome.org/archives/buildstream-list/2018-November/msg00106.html, implement a new command group called `source`. Move existing `track`, `fetch`, and the recently added `source-checkout` commands under this group. For `track` and `fetch`, this is a BREAKING change, as the old commands have been marked as obsolete. Using them will result in an error message that refers people to use the new versions, like `bst source fetch` instead of old `bst fetch`. `source-checkout` will now become `source checkout` (the dash has turned into a space), and is not a breaking change as it was added in the current development cycle. Note that the functionality to hide commands from help output was added only recently in Click, so the minimum version of Click that we now require is 7.0. Summary of changes: * _frontend/cli.py: Add `source` command group, mark previous versions as obsolete and hide them from the help output. * _frontend/complete.py: Fix completion for hidden commands. * setup.py: Bump Click minimum version to 7.0. * tests: Update to cope with the new command names. Fixes #814.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index c51e6d5bf..872e7da4e 100755
--- a/setup.py
+++ b/setup.py
@@ -346,7 +346,7 @@ setup(name='BuildStream',
# See issues #571 and #790.
'ruamel.yaml >= 0.15.41, < 0.15.52',
'pluginbase',
- 'Click',
+ 'Click >= 7.0',
'jinja2 >= 2.10',
'protobuf >= 3.5',
'grpcio >= 1.10',