summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBenjamin Schubert <contact@benschubert.me>2019-05-26 09:43:20 +0100
committerBenjamin Schubert <contact@benschubert.me>2019-05-29 19:47:57 +0100
commit41293b1badeb12689ea72cd42c2d68df492c4274 (patch)
tree47071727ebb605e6d34b2946857e5f6af6c87995 /setup.py
parent4e9b5803e7241cc87c14126d320dc744ac4798cf (diff)
downloadbuildstream-41293b1badeb12689ea72cd42c2d68df492c4274.tar.gz
_variables: Cythonize _internal_expand
Move _variables.py to be a Cython module. `_internal_expand` is a function that is called a lot in BuildStream. It is also entirely isolated and easy to cythonize.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index fe977c123..90aa74d31 100755
--- a/setup.py
+++ b/setup.py
@@ -391,6 +391,7 @@ def register_cython_module(module_name, dependencies=None):
BUILD_EXTENSIONS = []
+register_cython_module("buildstream._variables")
#####################################################
# Main setup() Invocation #