summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTristan Van Berkom <tristan.vanberkom@codethink.co.uk>2018-09-19 18:49:53 +0900
committerTristan Van Berkom <tristan.van.berkom@gmail.com>2018-09-19 11:08:33 +0000
commit16d9c6e55e23466ebb37232f492a87c4baad3cc1 (patch)
tree62cc1a11783333058f06902562e9a0715913a280 /setup.py
parentdddd6025705d4553f857695bb2b5e6bde6943556 (diff)
downloadbuildstream-16d9c6e55e23466ebb37232f492a87c4baad3cc1.tar.gz
_frontend/status.py: Completely remove the blessings dependency from BuildStream
This actually improves reliability of the status bar because we now disable it completely in the case that not all of the terminal escape sequences are supported on the given terminal. This replaces the few functions we were using, to move the cursor up one line, move it to the beginning of the line, and to clear a line, with low level functions provided by the curses module in the standard library. This change makes it easier for downstream distro package maintainers to package BuildStream, particularly on Fedora. Asides from changing _frontend/status.py, this commit includes the following changes: * _frontend/app.py: Use python isatty() function to determine if we are connected to a tty, instead of relying on blessings. * setup.py: Remove the dependency on blessings.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 0 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 781b55bcc..a0686ebea 100755
--- a/setup.py
+++ b/setup.py
@@ -297,7 +297,6 @@ setup(name='BuildStream',
'ruamel.yaml < 0.15.52',
'pluginbase',
'Click',
- 'blessings >= 1.6',
'jinja2 >= 2.10',
'protobuf >= 3.5',
'grpcio >= 1.10',