summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChandan Singh <csingh43@bloomberg.net>2019-04-24 22:53:19 +0100
committerChandan Singh <csingh43@bloomberg.net>2019-05-21 12:41:18 +0100
commit070d053e5cc47e572e9f9e647315082bd7a15c63 (patch)
tree7fb0fdff52f9b5f8a18ec8fe9c75b661f9e0839e /setup.py
parent6c59e7901a52be961c2a1b671cf2b30f90bc4d0a (diff)
downloadbuildstream-070d053e5cc47e572e9f9e647315082bd7a15c63.tar.gz
Move source from 'buildstream' to 'src/buildstream'
This was discussed in #1008. Fixes #1009.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py9
1 files changed, 5 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index c550fdd0b..267ca6fb4 100755
--- a/setup.py
+++ b/setup.py
@@ -128,7 +128,7 @@ def list_man_pages():
#
def list_testing_datafiles():
bst_dir = Path(os.path.dirname(os.path.abspath(__file__)))
- data_dir = bst_dir.joinpath('buildstream', 'testing', '_sourcetests', 'project')
+ data_dir = bst_dir.joinpath('src', 'buildstream', 'testing', '_sourcetests', 'project')
return [str(f) for f in data_dir.rglob('*')]
@@ -215,7 +215,7 @@ class BuildGRPC(Command):
"Install it via pip (pip3 install grpcio-tools).")
exit(1)
- protos_root = 'buildstream/_protos'
+ protos_root = 'src/buildstream/_protos'
grpc_tools.command.build_package_protos(protos_root)
@@ -335,7 +335,8 @@ setup(name='BuildStream',
'Mailing List': 'https://mail.gnome.org/mailman/listinfo/buildstream-list'
},
python_requires='~={}.{}'.format(REQUIRED_PYTHON_MAJOR, REQUIRED_PYTHON_MINOR),
- packages=find_packages(exclude=('tests', 'tests.*')),
+ package_dir={'': 'src'},
+ packages=find_packages(where='src', exclude=('tests', 'tests.*')),
package_data={'buildstream': ['plugins/*/*.py', 'plugins/*/*.yaml',
'data/*.yaml', 'data/*.sh.in',
*list_testing_datafiles()]},
@@ -353,7 +354,7 @@ setup(name='BuildStream',
#
('share/man/man1', list_man_pages()),
('share/bash-completion/completions', [
- os.path.join('buildstream', 'data', 'bst')
+ os.path.join('src', 'buildstream', 'data', 'bst')
])
],
install_requires=install_requires,