summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTristan Van Berkom <tristan.vanberkom@codethink.co.uk>2017-03-07 20:18:05 +0900
committerTristan Van Berkom <tristan.vanberkom@codethink.co.uk>2017-03-07 20:21:23 +0900
commit024f9685e66f757f74003d506bc0016574d19cb9 (patch)
treedc1ffb929009f89bc671827c0ffdb216780fc973 /setup.py
parent492e5897427b3e10d161e2fb6fbb145664bd1b0d (diff)
downloadbuildstream-024f9685e66f757f74003d506bc0016574d19cb9.tar.gz
setup.py: BuildStream now requires blessings.
Blessings gives us some code for positioning the cursor on terminals which support that (almost all terminals on linux), this lets us print some things always at the bottom of the output.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index cbbd5115a..3efe01e11 100755
--- a/setup.py
+++ b/setup.py
@@ -81,7 +81,8 @@ setup(name='buildstream',
'psutil',
'ruamel.yaml',
'pluginbase',
- 'Click'
+ 'Click',
+ 'blessings'
],
entry_points='''
[console_scripts]