summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorAkim Demaille <akim@epita.fr>2001-11-30 14:25:16 +0000
committerAkim Demaille <akim@epita.fr>2001-11-30 14:25:16 +0000
commit2c8a9dfa1d15d0588a7f45393aeae7305396a895 (patch)
treece37e6d118af87e6028d3b6ae78303b112066ff7 /lib/Makefile.am
parentf4e421e6e4e6f500c9721140c32f4d5bf300b185 (diff)
downloadbison-2c8a9dfa1d15d0588a7f45393aeae7305396a895.tar.gz
* configure.in (WARNING_CFLAGS): Add -Werror when possible.
(CFLAGS): Do not include the WARNING_CFLAGS here, since GNU Gettext doesn't compile cleanly, and dies with -Werror. * src/Makefile.am, lib/Makefile.am, tests/atlocal.in (CFLAGS): Include WARNING_CFLAGS here. * lib/xstrdup.c: Include xalloc.h, so that xstrdup be declared before being defined.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 51790f56..4fc4e488 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,7 +1,24 @@
-## Process this file with automake to produce Makefile.in -*-Makefile-*-
+## Copyright 2001 Free Software Foundation, Inc.
+
+## This program is free software; you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation; either version 2 of the License, or
+## (at your option) any later version.
+
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
+
+## You should have received a copy of the GNU General Public License
+## along with this program; if not, write to the Free Software
+## Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+## 02111-1307 USA
AUTOMAKE_OPTIONS = ansi2knr
+CFLAGS = @CFLAGS@ $(WARNING_CFLAGS)
+
noinst_LIBRARIES = libbison.a
INCLUDES = -I.. -I$(srcdir) -I$(top_srcdir)/src -I../intl