summaryrefslogtreecommitdiff
path: root/etc/Makefile.am
diff options
context:
space:
mode:
authorJoel E. Denny <jdenny@ces.clemson.edu>2006-12-26 18:09:53 +0000
committerJoel E. Denny <jdenny@ces.clemson.edu>2006-12-26 18:09:53 +0000
commit2e7944cbb21e10c130192f733abc1af5cd8b6eb7 (patch)
treedd66a92c26c7646c98ce05b5833119c09f9f6002 /etc/Makefile.am
parentc3d503425f8014b432601a33b3398446d63b5963 (diff)
downloadbison-2e7944cbb21e10c130192f733abc1af5cd8b6eb7.tar.gz
Update etc/bench.pl. Optimize push mode a little (the yyn change
deserves most of the credit). * Makefile.am (SUBDIRS): Add etc subdirectory. * configure.ac (AC_CONFIG_FILES): Add etc/bench.pl and etc/Makefile. * data/push.c (b4_declare_parser_state_variables): Move yyn, yyresult, yytoken, yyval, and yyloc declarations to... (yyparse or yypush_parse): ... here to improve performance. For yypush_parse invocations after the first, be sure to assign yyn its old value again. (yypstate_new): Don't bother initializing the yyresult field since the initial value isn't used. (yyn, yyresult, yytoken, yyval, yyloc): For each NAME in this list, remove the #define that, in push mode, set it to yyps->NAME. * etc/Makefile.am: New. * etc/bench.pl: Remove and build it instead from... * etc/bench.pl.in: ... this new file. Use @abs_top_builddir@ to invoke "tests/bison" from the build directory by default rather than just invoking "bison" from $PATH. (calc_grammar): Update push parser code: don't declare yylval globally, don't define yyparse_wrapper, and don't #define yyparse. (bench_grammar): Update to check all working combinations of yacc.c, push.c, impure, pure, pull, and push.
Diffstat (limited to 'etc/Makefile.am')
-rw-r--r--etc/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/etc/Makefile.am b/etc/Makefile.am
new file mode 100644
index 00000000..08fcfe67
--- /dev/null
+++ b/etc/Makefile.am
@@ -0,0 +1,18 @@
+## Copyright (C) 2006 Free Software Foundation, Inc.
+
+## This program is free software; you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation; either version 2 of the License, or
+## (at your option) any later version.
+
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
+
+## You should have received a copy of the GNU General Public License
+## along with this program; if not, write to the Free Software
+## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
+## 02110-1301 USA
+
+nodist_noinst_SCRIPTS = bench.pl