summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAkim Demaille <akim.demaille@gmail.com>2020-05-03 16:52:26 +0200
committerAkim Demaille <akim.demaille@gmail.com>2020-05-03 17:04:15 +0200
commite33cd4b8243a42d00de21e68be49509752393406 (patch)
tree1eeca8b26cdfe32cf358b3fa172d2f88d005ce6b /configure.ac
parent0669780ff8ad4136c71c29b45545a7793b144fa5 (diff)
downloadbison-e33cd4b8243a42d00de21e68be49509752393406.tar.gz
flex: fix incorrect use of Automake conditional
AM_CONDITIONAL does _not_ define a shell variable... Reported privately by Denis Excoffier. * configure.ac (LEX_CXX_WORKS): Fix its definition.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7e673b51..956ce4cd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -262,7 +262,8 @@ if ! "$LEX_IS_FLEX" || test "X$LEX" = X:; then
LEX=:
fi
AM_CONDITIONAL([FLEX_WORKS], [$LEX_IS_FLEX && $FLEX_SUPPORTS_HEADER_OPT])
-AM_CONDITIONAL([FLEX_CXX_WORKS], [$LEX_WORKS && test $bison_cv_cxx_works = yes])
+AM_CONDITIONAL([FLEX_CXX_WORKS],
+ [$LEX_IS_FLEX && $FLEX_SUPPORTS_HEADER_OPT && test $bison_cv_cxx_works = yes])
AC_PROG_YACC
AC_PROG_RANLIB
AC_PROG_GNU_M4