summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAkim Demaille <akim.demaille@gmail.com>2019-10-20 08:55:44 +0200
committerAkim Demaille <akim.demaille@gmail.com>2019-10-20 08:55:44 +0200
commite31f92495ce14a5d924b148c8ea1470003cc47c1 (patch)
treea46e57be1252368a49cbce3d7207b0f5ee465310 /configure.ac
parent54c5d5d1b400ccb1ee9a8d39140e804a4a42f02d (diff)
downloadbison-e31f92495ce14a5d924b148c8ea1470003cc47c1.tar.gz
build: disable -Wtype-limits, except in the test suite
The current implementation of lib/intprops.h results in "unsigned < 0" comparisons, which triggers warnings. See https://lists.gnu.org/archive/html/bug-bison/2019-10/msg00061.html * configure.ac (warn_common): Disable -Wtype-limits. (warn_tests): Restore it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0c1efde1..f055a68c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -94,9 +94,10 @@ AC_ARG_ENABLE([gcc-warnings],
[enable_gcc_warnings=no])
AM_CONDITIONAL([ENABLE_GCC_WARNINGS], [test "$enable_gcc_warnings" = yes])
if test "$enable_gcc_warnings" = yes; then
- warn_common='-Wall -Wextra -Wno-sign-compare -Wcast-align
+ warn_common='-Wall -Wextra -Wcast-align
-fparse-all-comments -Wdocumentation
-Wformat -Wimplicit-fallthrough -Wnull-dereference
+ -Wno-sign-compare -Wno-type-limits
-Wpointer-arith -Wshadow
-Wwrite-strings'
warn_c='-Wbad-function-cast -Wstrict-prototypes'
@@ -111,7 +112,7 @@ if test "$enable_gcc_warnings" = yes; then
# trick in the test suite to check some private implementation
# details for lalr1.cc.
warn_tests='-Wundef -pedantic -Wconversion
- -Wdeprecated -Wsign-compare -Wsign-conversion
+ -Wdeprecated -Wsign-compare -Wsign-conversion -Wtype-limits
-fno-color-diagnostics
-Wno-keyword-macro'