summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAkim Demaille <akim.demaille@gmail.com>2019-09-08 18:48:49 +0200
committerAkim Demaille <akim.demaille@gmail.com>2019-09-10 19:06:13 +0200
commitd80815ac23192b0b3a2ebc82e6a7e512968bacb1 (patch)
treea78161583bc8c7a1c5f8535c2e1893cf0fa0f382 /configure.ac
parent0b417c3479ca63a55cff5305a35e6eea3e7bc7a4 (diff)
downloadbison-d80815ac23192b0b3a2ebc82e6a7e512968bacb1.tar.gz
build: fix distcheck
* configure.ac (gl_LIBOBJS): Adjust so that the generated files are indeed the expected ones.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 83e2c972..6f323691 100644
--- a/configure.ac
+++ b/configure.ac
@@ -297,4 +297,15 @@ AC_SUBST([GCC])
AC_CONFIG_FILES([Makefile
po/Makefile.in
doc/yacc.1])
+
+# Fix LIBOBJS to give the Makefile the right file names. Otherwise
+# compilation works, but with unexpected file names, so clean rules don't
+# remove the actual files and distcheck fails.
+AC_CONFIG_COMMANDS_PRE([
+ case $am__api_version in
+ 1.14*|1.15*) gl_LIBOBJS=`echo "$gl_LIBOBJS" | sed -e 's, lib/, lib/lib_libbison_a-,g'`;;
+ *) gl_LIBOBJS=`echo "$gl_LIBOBJS" | sed -e 's, lib/, lib/libbison_a-,g'`;;
+ esac
+])
+
AC_OUTPUT