summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAkim Demaille <akim@lrde.epita.fr>2012-12-08 19:33:50 +0100
committerAkim Demaille <akim@lrde.epita.fr>2012-12-09 13:07:47 +0100
commitd4728d92c7c03279612271a5a4c1ae7e1e324971 (patch)
treef10f3ab655e8a6a8d484beeeb89014f14ca7f2a7 /configure.ac
parent09a1cd5e5865d8d8cf2c5e172f6f0fdaf6e01960 (diff)
downloadbison-d4728d92c7c03279612271a5a4c1ae7e1e324971.tar.gz
build: beware of Clang++ not supporting POSIXLY_CORRECT
* m4/c-working.m4 (BISON_LANG_COMPILER_POSIXLY_CORRECT): New. (BISON_C_COMPILER_POSIXLY_CORRECT): Use it. For consistency with C++, also define BISON_C_WORKS. * m4/cxx.m4 (BISON_CXX_COMPILER_POSIXLY_CORRECT): New. * configure.ac: Use it. * tests/atlocal.in: Get its result. Propagate properly CXX values when used to compile C. When POSIXLY_CORRECT, adjust BISON_C_WORKS and BISON_CXX_WORKS. * tests/local.at (AT_COMPILE): Use BISON_C_WORKS.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d14cb29e..e6403f4b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -135,8 +135,9 @@ if test "$enable_gcc_warnings" = yes; then
fi
BISON_TEST_FOR_WORKING_C_COMPILER
-BISON_TEST_FOR_WORKING_CXX_COMPILER
BISON_C_COMPILER_POSIXLY_CORRECT
+BISON_TEST_FOR_WORKING_CXX_COMPILER
+BISON_CXX_COMPILER_POSIXLY_CORRECT
AC_ARG_ENABLE([yacc],
[AC_HELP_STRING([--disable-yacc],