summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAkim Demaille <akim.demaille@gmail.com>2019-02-18 18:42:41 +0100
committerAkim Demaille <akim.demaille@gmail.com>2019-02-26 18:27:13 +0100
commitb12f9c76e2206fa5fd83904361eea197c2a714fa (patch)
treefec7367d4a78e81a636447916dad119f09d59279 /configure.ac
parent575b81411907191ce13a6f78a4b23b78263625df (diff)
downloadbison-b12f9c76e2206fa5fd83904361eea197c2a714fa.tar.gz
dlang: initial changes to run the calc tests on it
* configure.ac (DCFLAGS): Define. * tests/atlocal.in: Receive it. * data/skeletons/d.m4 (api.parser.class): Remove spurious YY. * data/skeletons/lalr1.d (yylex): Return an int instead of a YYTokenType, so that we can use characters as tokens. * examples/d/calc.y: Adjust. * tests/local.at: Initial support for D. (AT_D_IF, AT_DATA_GRAMMAR(D), AT_YYERROR_DECLARE(d)) (AT_YYERROR_DECLARE_EXTERN(d), AT_YYERROR_DEFINE(d)) (AT_MAIN_DEFINE(d), AT_COMPILE_D, AT_LANG_COMPILE(d), AT_LANG_EXT(d)): New. * tests/calc.at: Initial support for D. * tests/headers.at
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1b5343e7..507e6f64 100644
--- a/configure.ac
+++ b/configure.ac
@@ -192,6 +192,7 @@ BISON_CXX_COMPILER_POSIXLY_CORRECT
# D.
AC_CHECK_PROGS([DC], [dmd])
+AC_CHECK_PROGS([DCFLAGS], [])
AM_CONDITIONAL([ENABLE_D], [test x"$DC" != x])
# Java.