summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAkim Demaille <akim.demaille@gmail.com>2018-12-25 08:19:50 +0100
committerAkim Demaille <akim.demaille@gmail.com>2018-12-25 10:05:36 +0100
commita4ede8f85b0c9a254fcb01e5888cee1983095669 (patch)
treeec4bc084c53007c856c87f0496b9d9b1b85b4b65 /configure.ac
parent53f1a0b114d1f8e52d4a9708e31e4bcbd160aae1 (diff)
downloadbison-a4ede8f85b0c9a254fcb01e5888cee1983095669.tar.gz
package: make bison a relocatable package
Suggested by David Barto https://lists.gnu.org/archive/html/help-bison/2015-02/msg00004.html and Victor Zverovich. https://lists.gnu.org/archive/html/bison-patches/2018-10/msg00121.html This is very easy to do, thanks to work by Bruno Haible in gnulib. See "Supporting Relocation" in gnulib's documentation. * bootstrap.conf: We need relocatable-prog and relocatable-script (for yacc). * src/yacc.in: New. * configure.ac, src/local.mk: Instantiate it. * src/main.c, src/output.c (main, pkgdatadir): Use relocatable2. * doc/bison.texi (FAQ): Document it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 61b07ca1..a1247eae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -203,6 +203,7 @@ AC_ARG_ENABLE([yacc],
[do not build a yacc command or an -ly library])],
, [enable_yacc=yes])
AM_CONDITIONAL([ENABLE_YACC], [test "$enable_yacc" = yes])
+AC_CONFIG_FILES([src/yacc], [chmod +x src/yacc])
# Checks for programs.
AM_MISSING_PROG([DOT], [dot])